如果使用网络链接出现共享需要过时的 SMB1 协议无法创建映射,那么请看本文

我在输入网络驱动出现下面的错误

因为文件共享不安全,所以你不能连接到文件共享。

共享需要过时的 SMB1 协议,而此协议是不安全的,可能会使你的系统遭受攻击。你的系统需要 SMB2 或更高版本。

原因是 SMB1 是不安全的,所以微软在 win10 系统就不给使用,如果需要使用,需要使用管理员打开 Powershell 输入下面代码

Enable-WindowsOptionalFeature -Online -FeatureName smb1protocol

输入之后需要重新启动,如果还是无法使用,请输入下面代码

Get-WindowsFeature FS-SMB1

参见:https://support.microsoft.com/en-us/help/2696547/how-to-enable-and-disable-smbv1-smbv2-and-smbv3-in-windows-and-windows-server


本文会经常更新,请阅读原文: https://lindexi.gitee.io/lindexi/post/win10-%E4%BD%BF%E7%94%A8-SMB-v1.html ,以避免陈旧错误知识的误导,同时有更好的阅读体验。

知识共享许可协议 本作品采用 知识共享署名-非商业性使用-相同方式共享 4.0 国际许可协议 进行许可。欢迎转载、使用、重新发布,但务必保留文章署名林德熙(包含链接: https://lindexi.gitee.io ),不得用于商业目的,基于本文修改后的作品务必以相同的许可发布。如有任何疑问,请 与我联系